3

I like to wrap my text to 80 characters all the time, even when I am editing Markdown.

I have a problem when I open parentheses: it doesn't wrap right anymore. Since it is hard for me to explain it, and because a picture is worth a thousand words, here is a screeshot of what is happening:

screenshot of the problem

If anyone knows how to solve this, this would save my life.

  • 1
    It looks like you've accidentally :set lisp somewhere. It could be other settings such as 'cindent' as mentioned in @ntnn's answer. – Antony Jun 10 '16 at 14:47
2

set nocindent will do the trick. To have that persistent put it in a ftplugin: ~/.vim/ftplugin/markdown.vim e.g. (See :h ftplugin)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.