3

I am trying to configure the statusline using plugins "vim-airline" and "vim-airline-themes". And i get this character "☰"

Please help me understand why is this being displayed and how to fix this.

Following is my .vimrc settings:

" Backup Settings
set backup
set noswapfile
set backupdir=~/.vim/tmp/backup//
set undodir=~/.vim/tmp/undo//
set directory=~/.vim/tmp/swap//

" Vundle Settings
set nocompatible
filetype off

" set the runtime path to include Vundle and initialize
set rtp+=~/.vim/bundle/Vundle.vim
call vundle#begin()

" let Vundle manage Vundle, required
Plugin 'flazz/vim-colorschemes'
Plugin 'altercation/vim-colors-solarized'
Plugin 'VundleVim/Vundle.vim'
Plugin 'scrooloose/nerdcommenter'
Plugin 'scrooloose/nerdtree'
Plugin 'junegunn/vim-easy-align'
Plugin 'vim-airline/vim-airline'
Plugin 'MarcWeber/vim-addon-mw-utils'
Plugin 'tomtom/tlib_vim'
Plugin 'honza/vim-snippets'
Plugin 'garbas/vim-snipmate'
Plugin 'scrooloose/syntastic'
Plugin 'vim-airline/vim-airline-themes'

call vundle#end()

filetype plugin indent on

set tabstop=4
set softtabstop=4
set shiftwidth=4
set showmatch
set ruler
set nohlsearch
set incsearch
set cursorline
set wildmenu
set laststatus=2
set guitablabel=%t
syntax on
set showcmd
set autoindent
set hidden
set smartindent
set smarttab
set completeopt+=longest,menuone,preview

" Begin of airline settings
" Load powerline fonts/symbols for airline
let g:airline_powerline_fonts = 1

" AirLine Theme
:let g:airline_theme='badwolf'

" Enable the list of buffers
let g:airline#extensions#tabline#enabled = 1

" Show just the filename
let g:airline#extensions#tabline#fnamemod = ':t'

" End of airline settings

" Show two lines for the status line
set laststatus=2

" Make sure Vim returns to the same line when you reopen a file.
augroup line_return
     au!
         au BufReadPost *
                 \ if line("'\"") > 0 && line("'\"") <= line("$") |
        \     execute 'normal! g`"zvzz' |
        \ endif
augroup END

" Always show the last line
set display+=lastline

" Set encoding to utf-8
set encoding=utf-8

" Set dictionary
set dictionary=/usr/share/dict/words

" Syntastic settings
set statusline+=%#warningmsg#
set statusline+=%{SyntasticStatuslineFlag()}
set statusline+=%*

let g:syntastic_always_populate_loc_list = 1
let g:syntastic_auto_loc_list = 1
let g:syntastic_check_on_open = 1
let g:syntastic_check_on_wq = 0

let g:syntastic_enable_signs=1
let g:syntastic_error_symbol = '✗✗'
let g:syntastic_style_error_symbol = '✠✠'
let g:syntastic_warning_symbol = '∆∆'
let g:syntastic_style_warning_symbol = '≈≈'

vim-airline issue

1
  • 5
    Your question title says it doesn't display ☰, and your question body is something else.
    – muru
    Jun 8, 2016 at 12:22

2 Answers 2

11

That symbols stands for the last line number. So if it displays: 1/10 ☰ you know that you are on line 1 of 10 lines.

BTW: this symbol is in the documentation, search for maxlinenr.

2
  • Chqracter is mentioned as \u2630 under extend function in autoload/airline/init.vim
    – SibiCoder
    Jun 8, 2016 at 9:21
  • correct: U+2630 Dec:9776 TRIGRAM FOR HEAVEN Jun 8, 2016 at 14:29
2

enter image description here

For me, I use

let g:airline_symbols.maxlinenr= ''
4
  • Yes, after the update from Chris i did the same. Thanks. Jun 10, 2016 at 18:05
  • are you using tmux in that screenshot ?
    – Arithran
    May 15, 2017 at 13:21
  • @arithran - It is not Tmux. It is i3 Window Manager
    – Ratheesh
    Jan 12, 2018 at 7:05
  • @Wang could you kindly provide a screenshot of the whole of your configuration especially before let g:airline_symbols.paste? Thank you.
    – Edper
    Jan 10, 2023 at 5:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.