1

I'm trying to use this color scheme on my Ubuntu system. I installed the package using Option 1 in GitHub, and modified .vimrc as instructed.

It turns out that the colors displayed are different as in the author's website. C code has the following scheme according to the website:

enter image description here

The C++ code has the following scheme on my own machine:

enter image description here

How can I configure my .vimrc to have the same display effect as in the website? Or do I need to setup something on my terminal?

-------------Edited-------

gvim displays the color as expected. The only problem is vim on terminal

  • 2
    1/ Not working as expected is one of the main features of solarized. 2/ If you need help about the setup of your terminal it would be useful to tell us which terminal emulator you're using. – statox Jun 2 '16 at 7:24
  • How can I check what terminal I'm using? In the comment I left below (to the first answer), I list a command, and that command shows I'm using gnome. And I've downloaded the solarized scheme from this link (github.com/Anthony25/gnome-terminal-colors-solarized). What else shall I do? Thanks. – user3813057 Jun 2 '16 at 19:09
  • configure your term variable correctly and possibly also set :set t_Co=256 – Christian Brabandt Jun 3 '16 at 11:41
1

To be able to take advantage of that theme you must select an appropriate palette in your terminal settings as well.

enter image description here

screenshot

If you don't find that palette in your terminal settings (for instance if you are on Ubuntu 14.04 LTS) you must install a solarized Theme for the gnome-terminal first.

  1. Get the repo from gnome-terminal-colors-solarized on Github
  2. create a new profile for your terminal to easily get rid of that color-scheme in case you don't like it enter image description here
    enter image description here
  3. switch to that profile
    enter image description here
  4. now install the color-scheme with ./install.sh from the cloned git-repo, you will be asked two questions, be sure to answer the second one with the profile you just created

Please select a Gnome Terminal profile:
1) Default
2) solarized
#? 2

Now you are ready to install the vim-solarized theme.

  • How did you open this panel? I opened the System Settings at the task bar, and clicked the Color icon, it listed the monitor device and and a Add profile button. What's next? – user3813057 Jun 2 '16 at 0:26
  • @user3813057 that's the terminal's profile preferences, not system settings. – muru Jun 2 '16 at 7:34
  • @guntbert I'm using gnome term, at least the command cat /etc/alternatives/x-terminal-emulator | grep exec shows exec('gnome-terminal',@args). I've downloaded solarized color scheme from this (github.com/Anthony25/gnome-terminal-colors-solarized) link, and run the ./install.sh command. However, when I open the palette, there is no Solarized option, and the vim in terminal still does not display as expected. What else shall I do? – user3813057 Jun 2 '16 at 19:06
  • @user3813057 Strange, I am running Ubuntu 16.04 and the two solarized color-schemes are built in. I checked and help.gnome.org/users/gnome-terminal/stable/app-colors.html.en says so too. – guntbert Jun 3 '16 at 18:51
  • I'm using Ubuntu 14.04LTS, which has no solarized-light/dark color-scheme. Is there any other way to set the Ethan Solarized color? – user3813057 Jun 7 '16 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.