1

This question already has an answer here:

I'm currently configuring vim on my work computer and I'm encountering a problem with the colour scheme.

I'm using pathogen and all of my plugins are working well. I downloaded the harlequin colour scheme and dropped it into my bundle folder just as I have with previous computers. When I go to my vimrc file and type :colorscheme I can browse the available options and indeed harlequin is one of them. When I select harlequin however, I just get the default colorscheme. Not surprisingly when I type colorscheme harlequin in my vimrc, it just maintains the default.

Suggestions? (here is a copy of my vimrc)

 1 "Use pathogen plugin manager
 2 execute pathogen#infect()
 3 
 4 "change colour scheme
 5 colorscheme harlequin
 6 
 7 "set line numbering
 8 set number
 9 
10 "turn on status bar
11 set laststatus=2
12 
13 "syntax and indenting on
14 syntax on
15 filetype plugin indent on
16 
17 

marked as duplicate by Rich, peterh, Herb Wolfe, jamessan, Martin Tournoij Feb 19 '18 at 22:44

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

-1

romainl found the problem. My terminal didn't have 256 color, which konsole does actually support. Fixed it by changing the path and getting the proper script 256color.pl

Not the answer you're looking for? Browse other questions tagged or ask your own question.