7

I have a file that has decided to scroll synchronously when I open it in a second window and start scrolling. scrollbind and diff are set to off. (:set scrollbind? prints noscrollbind and :set diff? prints nodiff.)

What else can I try?

I'm using neovim.

  • what does the scrollopt say ? – nobe4 Apr 21 '16 at 10:49
  • scrollopt=ver,jump – Praxeolitic Apr 21 '16 at 10:51
  • try set it to null, set scrollopt=, maybe it will solve the issue... – nobe4 Apr 21 '16 at 10:51
  • @Nobe4 That didn't work. :-/ – Praxeolitic Apr 21 '16 at 10:52
  • 1
    set cursorbind? – Christian Brabandt Apr 21 '16 at 11:41
12

As Christian Brabandt suggested in a comment, this can be caused by the 'cursorbind' setting.

From :help 'cursorbind':

When this option is set, as the cursor in the current window moves other cursorbound windows (windows that also have this option set) move their cursors to the corresponding line and column.

You can use :verbose set cursorbind? to find out what is switching this setting on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.