4

My color scheme has:

hi Cursor       ctermfg=black   ctermbg=red cterm=NONE

This is confirmed using hi Curosr:

Cursor         xxx ctermfg=0 ctermbg=1 guifg=black guibg=orange

However, I'm not getting the desired color in cygwin's mintty. When the cursor blinks, I get a white back ground with black letters (which is visible enough, since the surrounding text is white on blue). Unfortunately, it doesn't show up well with my CursorLine and CursorColumn colors. How can I troubleshoot the cause for my Cursor colors being ignored?

  • The cursor color is handled by your terminal emulator, not by Vim. – romainl Apr 4 '16 at 6:04
  • OK, so does that mean the Cursor highlight group is not meaningful for mintty? Would this be the answer to the question? If so, it might be useful for you to enter it as an answer (just a suggestion). – user2153235 Apr 4 '16 at 6:42
  • I navigated to the mintty options and checked what the foreground, background, and cursor colours were. Setting the cursor color there seems to work. Thanks. Again, feel free to enter your answer as an official answer. – user2153235 Apr 4 '16 at 6:58
8

Playing with the Cursor highlight group is a waste of time because the cursor color is handled by your terminal emulator, not by Vim.

  • On Cygwin's mintty terminal, the terminal emulator parameters are accessed via the pulldown menu. Click on the Cygwin icon on the upper left corner of the terminal window and select Options.... – user2153235 Apr 4 '16 at 11:58
  • What about the foreground text? Surely vim should know where the cursor is. – Mateen Ulhaq Jun 2 '18 at 6:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.