2

I have an ugly orange triangle appearing in the airline bar in my nvim regardless of the theme I use. Take a look at that :

Look at the right side on the airline bar

Shocking, isn't it ? Now do you have an idea on how to correct this ?

  • 4
    High possibility this is because of this issue: github.com/vim-airline/vim-airline/issues/157 – tokoyami Mar 30 '16 at 19:21
  • @tokoyami I don't understand, do they give a solution in this issue ? – ChiseledAbs Mar 31 '16 at 17:44
  • 1
    There is a workaround, bling's second comment. I don't know much about the status line configuration of airline though so I can't tell exactly how to apply it. If noone decides to tackle it, I can probably try during the weekend. – tokoyami Mar 31 '16 at 21:57
3

The orange section by default should be the warning one:

let g:airline_section_warning (ycm_warning_count, whitespace)

You can find a list of all sections at the end of the 'CUSTOMIZATION' section of the airline help (:help airline-customization).

It gets filled usually by the whitespace extension which is on by default.

Use the following in you vimrc file to "close" the section. I added the error section too, because it shows on my system so it might on yours in time (if you are using an older version at the moment):

let g:airline_section_warning = ''
let g:airline_section_error = ''

This fully disables the section so you won't be seeing anything in it. I think this is what the issue I linked in the comments is about: hiding the section when no information is available and showing it when there is. Currently you seem to get only one of them.

3

According to Christian Brabandt this is how airline works. He created a solution that requires setting the variable let g:airline_skip_empty_sections = 1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.