2

I'm using old Debian linux an vim version 7.1.314. I would like to edit eclipse .cproject file that build using XML syntax. Currently vim shows not colored information. I found vim plugin that I hope wil solve my problem xml.vim . I hve done evrything as described in installation manual:

ln -s xml.vim docbk.vim
ln -s xml.vim xsl.vim
ln -s xml.vim html.vim
ln -s xml.vim xhtml.vim
cd ..
mkdir indent
echo "let b:did_indent = 1" > ~/.vim/indent/xml.vim 
echo "let b:did_indent = 1" > ~/.vim/indent/xsl.vim 
echo "let b:did_indent = 1" > ~/.vim/indent/html.vim 
echo "let b:did_indent = 1" > ~/.vim/indent/xhtml.vim 

After I have restarted vim and opened file I found the same old not colored text.

How to be sure vim has loaded plugin? Where might be problem?

UPD.

After I have placed line filetype indent on in ~/.vimrc I got error while loading vim:

Error detected while processing /root/.vimrc:
line    1:
E319: Sorry, the command is not available in this version: filetype indent on
Press ENTER or type command to continue

UPD :version uputput

VIM - Vi IMproved 7.1 (2007 May 12, compiled Oct 17 2008 18:03:34)
Included patches: 1-314
Compiled by jamessan@debian.org
Small version without GUI.  Features included (+) or not (-):
-arabic -autocmd -balloon_eval -browse +builtin_terms -byte_offset -cindent -clientserver -clipboard -cmdline_compl +cmdline_hist -cmdline_info -comments -cryptv -cscope -cursorshape -dialog -diff -digraphs -dnd -ebcdic -emacs_tags -eval -ex_extra -extra_search -farsi -file_in_path -find_in_path -folding -footer +fork() -gettext -hangul_input +iconv -insert_expand +jumplist -keymap -langmap -libcall -linebreak 
-lispindent -listcmds -localmap -menu -mksession -modify_fname -mouse -mouse_dec -mouse_gpm -mouse_jsbterm -mouse_netterm -mouse_xterm +multi_byte -multi_lang -mzscheme -netbeans_intg -osfiletype -path_extra -perl -printer -profile -python -quickfix -reltime -rightleft -ruby -scrollbind -signs -smartindent -sniff -statusline -sun_workshop -syntax -tag_binary -tag_old_static -tag_any_white -tcl +terminfo -termresponse 
-textobjects -title -toolbar -user_commands -vertsplit -virtualedit +visual -visualextra -viminfo -vreplace +wildignore -wildmenu +windows +writebackup -X11 +xfontset -xim -xsmp -xterm_clipboard -xterm_save 
   system vimrc file: "$VIM/vimrc"
     user vimrc file: "$HOME/.vimrc"
      user exrc file: "$HOME/.exrc"
  fall-back for $VIM: "/usr/share/vim"
Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H     -g -O2 -O2 -g -Wall -DTINY_VIMRC        
Linking: gcc   -Wl,--as-needed -L/usr/local/lib -o vim    -lncurses  -lselinux 

UPD

After I did simple aptitude istall vim I got following in :version output:

:version
VIM - Vi IMproved 7.1 (2007 May 12, compiled Oct 17 2008 18:11:28)
Included patches: 1-314
Compiled by jamessan@debian.org
Huge version without GUI.  Features included (+) or not (-):
+arabic +autocmd -balloon_eval -browse ++builtin_terms +byte_offset +cindent -clientserver -clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments +cryptv +cscope +cursorshape +dialog_con +diff +digraphs -dnd -ebcdic +emacs_tags +eval +ex_extra +extra_search +farsi +file_in_path +find_in_path +folding -footer +fork() +gettext -hangul_input +iconv +insert_expand +jumplist +keymap +langmap +libcall +linebreak 
+lispindent +listcmds +localmap +menu +mksession +modify_fname +mouse -mouseshape +mouse_dec +mouse_gpm -mouse_jsbterm +mouse_netterm +mouse_xterm +multi_byte +multi_lang -mzscheme -netbeans_intg -osfiletype +path_extra -perl +postscript +printer +profile -python +quickfix +reltime +rightleft -ruby +scrollbind +signs +smartindent -sniff +statusline -sun_workshop +syntax +tag_binary +tag_old_static -tag_any_white -tcl 
+terminfo +termresponse +textobjects +title -toolbar +user_commands +vertsplit +virtualedit +visual +visualextra +viminfo +vreplace +wildignore +wildmenu +windows +writebackup -X11 -xfontset -xim -xsmp -xterm_clipboard -xterm_save 
   system vimrc file: "$VIM/vimrc"
     user vimrc file: "$HOME/.vimrc"
      user exrc file: "$HOME/.exrc"
  fall-back for $VIM: "/usr/share/vim"

Now xml looks formated, but still no colors

  • 1
    show the output of :version please – Christian Brabandt Feb 12 '16 at 11:56
  • 1
    I have updated question body with :version output – vico Feb 12 '16 at 12:14
  • 6
    Lookg at the version output. -syntax, -eval This means, syntax highlighting is not enabled in your vim build and plugins won't work. You need to get at least a normal build (you have a small version) – Christian Brabandt Feb 12 '16 at 12:29
  • 1
    Then how to get normal vim build for my old linux? – vico Feb 16 '16 at 11:48
  • 2
    Have you tried :syntax enable? – fruglemonkey Feb 17 '16 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.