6

Is there any way to show non-printable characters by default, for all windows, buffers, tabs, opened inside Vim (including man pages, netrw buffers, etc.)?

Additionally I also like to see the non-printable characters for all the buffers. And here goes my _vimrc lines for that:

    scriptencoding utf-8
    set listchars+=space:·
    set listchars=eol:¶,tab:» ,trail:~,extends:>,precedes:<,space:·
    set list 

And again, this is working for all the file buffers. As soon as I open up a manual page or netrw directory listing or NERDTree buffer, I have to run :se list for each buffer.

Can anybody help me or at least give me some hint to get this setting done?

4

You can get 'list' on all the windows by using the following:

augroup setList
   au!
   au BufWinEnter *  set list
augroup END

The (long) explanation of why it doesn't work only by setting it on the vimrc can be found at :help local-options.

  • Thanks for showing me the light...now i can understand...how to use au...and how implement as well.... – Cylian Feb 11 '16 at 19:00
  • @Cylian Glad I could help :) – mMontu Feb 11 '16 at 19:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.