7

My spellchecker wants me to begin every sentence with a capital letter, i.e., it underlines lowercase characters after full stop. Can I make it stop?

6

There's the 'spellcapcheck' option; from the help:

Pattern to locate the end of a sentence. The following word will be checked to start with a capital letter. If not then it is highlighted with SpellCap hl-SpellCap (unless the word is also badly spelled).

The default value is [.?!]\_[\])'" \t]\+, but it may be set when loading a spell file (to accommodate the language's specific rules).

If you want to disable it, you should therefore use :set spellcapcheck= after using :set spell and :set spelllang. Unfortunately, there doesn't seem to be an autocmd to help you here, but you can use a mapping, e.g.:

nnoremap <Leader>ss :set spell!<CR>:set spellcapcheck=<CR>
nnoremap <Leader>sn :set spelllang=nl<CR>:set spellcapcheck=<CR>
nnoremap <Leader>se :set spelllang=en_gb<CR>:set spellcapcheck=<CR>
nnoremap <Leader>su :set spelllang=en_us<CR>:set spellcapcheck=<CR>
nnoremap <Leader>sd :set spelllang=de_de<CR>:set spellcapcheck=<CR>
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.