7

I have problems getting python3 support working in neovim. I have followed the instructions in :help nvim-python, but :echo has('python3') returns 0.

I have tried installing the neovim python modules both from git and pip, and also the AUR on arch linux, but :echo has('python3') still returns 0.

I tried setting the path to python manually in neovim, and I also tried rebuilding neovim from source from github after installing python modules, but still nothing.

Edit: I found out clipboardprovider didn't work either.

6

Okay, I found out there was an error in my init.vim. I was overwriting the runtimepath instead of appending to it.

I had this line:

set runtimepath=~/.vim,/var/lib/vim/addons,/usr/share/vim/vimfiles,/usr/share/vim/vim74,/usr/share/vim/vimfiles/after,/var/lib/vim/addons/after,~/.vim/after

Change to this:

set runtimepath+=~/.vim,/var/lib/vim/addons,/usr/share/vim/vimfiles,/usr/share/vim/vim74,/usr/share/vim/vimfiles/after,/var/lib/vim/addons/after,~/.vim/after

And then it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.