4

I'm using VIM7.4.488 on ubuntu 15.04 system. I use command :setlocal spell spelllang=en_us for spell checking.

It can capture some spelling error as well as words like htb, Cref, iffalse. However, it did not detect the error spelling tehrmal (thermal). Then I tried ge agw obr tbg., and type the command again, the obvious incorrect words are undetected either.

Any way to fix this problem?

  • 1
    end_us? Is the end nigh? :D – muru Jan 28 '16 at 23:38
  • 1
    Does this behaviour occur in an empty buffer? Do you still get this error if you enter :set ft= – fruglemonkey Jan 29 '16 at 0:11
  • 1
    Are you using spelllang=end_us? Because that's not valid. Also make sure spell checking is actually enabled with :set spell? and that you haven't accidentally added those words to the dictionary with zg in ~/.vim/spell/en-utf-8.add (assuming you're using utf-8). – Martin Tournoij Jan 29 '16 at 2:08
  • 1
    @muru Thanks for pointing out. I've corrected the typo in OP. – user3813057 Jan 29 '16 at 2:13
  • 1
    @JeffreyLai Thanks for your answer. It behaves normally in an empty buffer. And the problem is fixed using :set ft=. Please post your answer in the answer area so that I can accept it. – user3813057 Jan 29 '16 at 2:17
5

Most likely you've got some conflict with file syntax, which can be confirmed by turning that off:

:syn off

For example, by default in vim files (Such as your .vimrc) spell checking is only performed in comments.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.