17

Vim's Downloads page says the 64-bit version is discontinued:

Win64

The 32-bit version of Vim runs fine on 64-bit windows. There was a 64-bit binary, but it wasn't used much and maintenance stopped.

Which is fine, I suppose, except that 32-bit Vim doesn't pick up 64-bit Python. has('python')? 0.

What are my options for installing 64-bit Vim specifically (including GVim) on Windows, with as much plugin support as possible?


The binary from Cream is also apparently 32-bit (see the version.txt). As for Cygwin, I'm not sure about getting GVim running in it (it apparently needs DISPLAY set, which would indicate the need for X server, which is yet another complication over the complexity of Cygwin itself).

I have MinGW installed (and it is rather outdated, admittedly), so I could make some attempt at compiling it myself.

The Vim Wikia suggests https://tuxproject.de/projects/vim/x64/, which has a rather ominous instruction:

You'll need to copy the appropriate DLL files to your Vim directory to make them work. They're not included.

To my Vim directory? Will https://tuxproject.de's build not pick up Python installed elsewhere?


So, I'd like to install 64-bit Vim so that:

  • it works out-of-the-box with Python installed using the official Python binaries (preferably both 2 and 3, if that's possible, and the latest versions)
  • it is easy to keep updated
  • the requirements for having it installed are a minimum (... so a Cygwin installation, if workable, should be minimal)
14

I think tuxproject.de is the way to go and I think, it will pick up Python dll, if they are in your path and are also 64bit. The easy way is to copy them to your .vim directory, to make sure vim will find them when trying to load them.

There is another alternative (and I really hope this will become official). We are trying to build binary Vims as part of the CI testing with appveyor, so that eventually for every patch there will be a corresponding Windows Vim version 32bit and 64bit available. Current snapshots are available here and here. Note they are unofficial and not regularly maintained. But I really hope, something like this will be available with the not too far away release of Vim 7.5

05.02.2016 We have now un-official (or almost official) binaries in the new repository vim-win32-installer. Feedback is appreciated.

7

I was just looking this information up and I only found one x64 version not mentioned by Christian. Here's a summary of the interfaces each version supports today to give you an idea of how well they stay up to date:

Nearly Official

  • Vim 7.4.1832 and x64
  • Interfaces: ActivePerl 5.22, ActiveTcl 8.6, LuaBinaries 5.3, Python 2.7, Python 3.4, Racket 6.4, RubyInstaller 2.2

TuxProject.de

  • Vim 7.4.1832 and x64
  • Interfaces: Perl 5.22.2, Python 2.7.11, Python 3.5.1, Racket 6.4.0.4, Ruby 2.3.0, Lua 5.3.2, Tcl 8.6.4, libXpm.
  • Python 2.7.11 requires you to rename a registry key when using the x86 builds.

Alexander-Shukaev (formerly Haroogan)

  • Vim 7.4.417 and x64
  • Interfaces: python 2.7, python 3.4, ruby 2.0.0, lua 5.2, perl 5.18.
1

The other answers really only point you to .zip files or self-extracting archives, not to installers. (TuxProject's "complete-x64.exe" file is a self-extracting archive, not an installer.)

Here's an easy way to install 64-bit Vim.

The following steps will install a full 64-bit Vim on Windows, including a working "Edit with Vim" context-menu item in Windows Explorer. I have no idea whether or not Python will work. Try it and see, then edit this answer to inform other people.


To install Vim

A) Install Chocolatey, which is a high-level package-management system for Windows. It's kind of like apt-get or yum for Linux, but perhaps not quite as elegant.

B) Open a command prompt. Make sure to launch it as Administrator.

C) If you don't have "vcruntime140.dll" installed, or if you're not sure whether or not you have it, install it. You should use the -y switch, or else Chocolatey will ask you a lot of questions. Enter this command:

choco install vcredist2015 -y

D) Install 64-bit Vim:

choco install vim-tux -y

Chocolatey will install Vim automatically, with no questions asked.

To do an upgrade by entering just one command

Run this:

choco upgrade all -y

This will make Chocolatey upgrade everything that it's installed. This is automatic, with no questions asked. Please be patient.

  • The vim-win32-installer does come with a installer as the name suggests. – Christian Brabandt Jul 25 '17 at 20:17
0

UPDATED FOR VIM 8.x

For Windows you can always grab the very latest patched version of Vim 8.x compiled against the latest external libraries here: Vim downloads

At the time of posting the most current versions:

Latest compiled update: 2017-02-23

Vim version: 8.0.0363 Official patch log

Libraries used: Perl 5.24.1, Python 2.7.12, Python 3.6.0, Racket 6.7, Ruby 2.4.0, Lua 5.3.3, Tcl 8.6.4, and libXpm

  • 1
    Since this is for Tuxproject.de, this should be an edit to idbrii's answer. – muru Feb 25 '17 at 11:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.