3

I use Vim v7.4 on a Windows laptop. Recently, I copied my .vimrc from a Mac, only to find that every time I leave insert mode, a sequence of strange characters will appear:

enter image description here

These characters (right after the cursor) don't actually exist, and they always follow the current position of cursor whenever I switch back to normal mode.

I tried this with a blank .vimrc, and the issue didn't occur. However, my current .vimrc is pretty big, and I have no idea how to debug this.

Does anyone know how to solve this issue?

  • 3
    You probably have something in your vimrc (which you didn't post...). Probably something in a InsertLeave autocmd, or a t_* setting. Also see: How do I debug my vimrc file?. – Martin Tournoij Dec 24 '15 at 14:10
  • 1
    Thank you, I'll try to comment those things out and see what's the change. – nightire Dec 24 '15 at 14:33
  • 1
    Elaborating on what @Carpetsmoker said, try searching for t_EI setting in your .vimrc, which causes a terminal escape sequence to be sent when leaving insert mode. – Rich Jan 15 '16 at 12:00
  • 1
    @nightire Did you ever find the problem? – John O'M. Feb 27 '16 at 18:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.