1

For some reason when I execute a hardcopy command vim doesn't print the header, only text. Here are my setting for printoptions as well as printheader

printoptions=left:3pc,number:y,syntax:n,header:2
printheader=%<%f%h%m%=Page %N

Does anybody know why it doesn't print the header?

1 Answer 1

2

I tried with your very own settings and I encountered no issue. If I understand the help correctly, by default Vim will use A4 as the medium size; maybe your output gets on a smaller medium size than A4? Could you try to add something like: paper:letter in your printoptions. Does it change something? What exact size of medium are you using?

2
  • I think questions for further clarifications to the OP should go into comments below his question.
    – peterh
    Nov 6, 2015 at 18:27
  • You are correct. I had to add a paper:letter option
    – flashburn
    Nov 6, 2015 at 21:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.