2

I recently had an 'rm -rf' related mishap in my home directory ( Ubuntu 14.04 installation ).

Vim ( v 7.4.52 ) and the add-on package 'vim-youcompleteme' had been installed prior to the mishap and worked perfectly .

After recovering from my goof-up, I noticed that the completion features from 'vim-youcompleteme' no longer seemed to be working.

I tried complete removal of the package ( apt-get purge vim-youcompleteme ) and subsequent re-installation, hoping that this would reinstate the aforementioned add-on package and its capabilities. This didn't help.

I suspect something in the resource / settings data must have gotten corrupted.

I am hoping for suggestions that would lead to the resurrection of the completion feature for Vim.

Many thanks in advance!

3

The addon packages in Debian/Ubuntu are typically managed using the vim-addon-manager package.

Once an addon package is installed, you run vam install <addon> to enable it in your user's config. In this case, you likely want to run vam install youcompleteme but vam list can confirm the addon name.

  • Hi there @jamessan. thanks for your solution. It worked ...and I learned something new about this very important tool we use ( Vim ). – darbehdar Oct 28 '15 at 7:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.