1

I recently found out about vim-pathogen, and installing vim plugins on my Mac and on remote shared Linux machines has been working great. However, I can't get vim-pathogen working on one remote shared Linux machine I use. I tried using vim-pathogen on an external Linux cluster, but if I have the recommended execute pathogen#infect() line in my .vimrc file, Vim suddenly won't even open if I clone a plugin repository in my .vim/bundle directory. Below is a copy of one of my sessions where I tried to get vim-pathogen working. I had the same problem with other plugins, so it's not just vim-autoclose. How do I go about getting vim-pathogen working? I have Vim 7.0 on this machine.

lindsb@rrlogin:~$ ls .vim
lindsb@rrlogin:~$ cat .vimrc
lindsb@rrlogin:~$ mkdir -p ~/.vim/autoload ~/.vim/bundle && \
> curl -LSso ~/.vim/autoload/pathogen.vim https://tpo.pe/pathogen.vim
lindsb@rrlogin:~$ ls .vim/*
.vim/autoload:
pathogen.vim

.vim/bundle:
lindsb@rrlogin:~$ echo -e "execute pathogen#infect()\nsyntax on\nfiletype plugin indent on" > .vimrc
lindsb@rrlogin:~$ cat .vimrc
execute pathogen#infect()
syntax on
filetype plugin indent on
lindsb@rrlogin:~$ vi
lindsb@rrlogin:~$ git clone https://github.com/Townk/vim-autoclose .vim/bundle/vim-autoclose
Cloning into '.vim/bundle/vim-autoclose'...
remote: Counting objects: 326, done.
remote: Total 326 (delta 0), reused 0 (delta 0), pack-reused 326 
Receiving objects: 100% (326/326), 97.85 KiB | 0 bytes/s, done.
Resolving deltas: 100% (132/132), done.
Checking connectivity... done.
lindsb@rrlogin:~$ ls .vim/*
.vim/autoload:
pathogen.vim

.vim/bundle:
vim-autoclose
lindsb@rrlogin:~$ vi
*** glibc detected *** vim: double free or corruption (fasttop): 0x00000000197ee800 ***
======= Backtrace: =========
/lib64/libc.so.6[0x326da714af]
/lib64/libc.so.6(cfree+0x4b)[0x326da757ab]
vim(clear_tv+0x4e)[0x453c7e]
|      |      |
|      |      |
V      V      V
[ a bunch more lines of similar error output ]
  • I have a Linux VM I can play with. Can you comment with a link to the instructions you've been following? Also, which Linux distribution are you using? – Wildcard Oct 25 '15 at 13:42
  • Please use a newer vim. This looks like a bug and most likely this has been fixed – Christian Brabandt Oct 25 '15 at 16:11
  • @Wildcard Here's my Linux distribution (not sure how much info you need):lindsb@rrlogin:~$ lsb_release -a LSB Version: :core-3.1-amd64:core-3.1-noarch:graphics-3.1-amd64:graphics-3.1-noarchDistributor ID: ScientificSL Description: Scientific Linux SL release 5.5 (Boron) Release: 5.5 Codename: Boron lindsb@rrlogin:~$ cat /proc/version Linux version 2.6.18-371.8.1.el5 (mockbuild@norob.fnal.gov) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-54)) #1 SMP Thu Apr 24 14:03:58 CDT 2014 – Ben Lindsay Oct 25 '15 at 17:55
  • @ChristianBrabandt I don't have root access on this machine. I might consider a local installation of vim if that's not too difficult and there's no other way around it. – Ben Lindsay Oct 25 '15 at 18:00
  • @ChristianBrabandt I installed the latest version of vim locally, and the bug is gone. However, the local version of vim takes about 1 second to open whereas the global installation opened practically instantaneously. Any idea why that is or how to get around that? – Ben Lindsay Oct 25 '15 at 18:38
2

As Christian Brabandt suggested, my issue was caused by an old version of vim. I installed locally by cloning the vim git repo then executing ./configure --prefix=$HOME/usr/vim && make && make install within the top directory of the vim repo. ($HOME/usr/vim is where I wanted vim installed) The new vim worked great with the pathogen plugin installation method, but it opened really slowly. By analyzing the startup time with vim --startuptime out.log I found that setting up the clipboard was taking up most of the startup time. Following the instructions in this post I found that vim -X opened much faster, so I added set clipboard=exclude:.* to my .vimrc file. Now everything works great.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.