1

Somehow every line in my Vim is bold. I'm using Consolas, which has a Bold typeface. Also, after leaving Vim, terminal is shown in Regular. The screenshot shows a small document that should have both Regular and Bold. It only seems to change in color a bit.

enter image description here

I've had it working before, but even then, the difference between Regular and Bold was an absolute minimum. Using Vim with SPF13 and iTerm2.

3
  • Maybe you accidentally selected "Consolas bold" as the font for your terminal? Oct 22 '15 at 11:46
  • I’m wondering if this could be because of Vim’s theme. Some terminal emulators have a setting to draw brighter colors with bold. Oct 29 '15 at 11:38
  • It could be related to what $TERM is reporting as well. If it is set incorrectly then t_Co might be set to a low number. In my terminal if t_Co is 8 or less, than all text is bold.
    – Alex
    Nov 11 '15 at 19:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.