2

When I type some mathematical expressions in Tex files using Vim, e.g. a_{2} = a_{1} + a_{0}, it is displayed in a human readable way like a2 = a1 + a0. (Actually the numbers are of a smaller font, but I don't know how to format mathematical expressions in Vi and Vim beta.) What I would like to know is what plugin is causing this effect. I just want to disable this feature since it's really annoying when moving cursor because it looks as if each of the numbers is consisted of one character but actually I have to type arrow keys several times to move from the number to the neighboring characters since the numbers correspond to something like _{2}.

I use Neobundle for managing plugins and I use the following plugins,

NeoBundle 'Shougo/neocomplete'
NeoBundle 'Shougo/neosnippet'
NeoBundle 'Shougo/neosnippet-snippets'
NeoBundle 'tpope/vim-fugitive'
NeoBundle 'ctrlpvim/ctrlp.vim'
NeoBundle 'flazz/vim-colorschemes'
NeoBundle 'Shougo/unite.vim'
NeoBundle 'thinca/vim-quickrun'
NeoBundle 'davidoc/taskpaper.vim'
NeoBundle 'itchyny/lightline.vim'
NeoBundle 'altercation/vim-colors-solarized'
NeoBundle 'git://git.wincent.com/command-t.git'
NeoBundle 'vim-latex/vim-latex'
NeoBundle 'surround.vim'
NeoBundle 'mattn/emmet-vim'
NeoBundle 'kchmck/vim-coffee-script'
NeoBundle 'vim-scripts/sudo.vim'
NeoBundle 'Shougo/neomru.vim'
NeoBundle 'tomtom/tcomment_vim'
NeoBundle 'vim-scripts/AnsiEsc.vim'
NeoBundle 'hallison/vim-markdown'
NeoBundle 'elzr/vim-json'
NeoBundle 'xolox/vim-session'
NeoBundle 'xolox/vim-misc'
NeoBundle 'tmhedberg/SimpylFold'
NeoBundle 'vim-ruby/vim-ruby'

I thought vim-latex has something to do with this but it turned out that it doesn't.

1

This functionality comes from the internal LaTeX plugin. See :h tex-conceal and :h g:tex_conceal. You can turn it off either by setting conceallevel=0 or by letting g:tex_conceal=''. To be more precise, you can use either of the following lines in your vimrc file:

let g:tex_conceal = ''
set conceallevel = 0

I propose that you read :h conceallevel before you set it to 0, since this will have an effect also for other file types.

  • 1
    Thank you very much! This feature was blind spot for me :) – hitochan Oct 19 '15 at 2:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.