1

I've turned on filetype indent and plugins on with the following in my vimrc file:

filetype indent plugin on

Everything is fine when I open a file from terminal, but if I open another buffer through the :edit command, it doesn't seem to load the any of the indent settings (doesn't expand tabs, different shiftwidth, etc). The first buffer has all the correct settings. All subsequent files opened with edit do not. Any idea why and how I might fix this?

  • I guess there is something wrong in your vimrc. You can try an auto command as well. – SibiCoder May 13 '16 at 18:15

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.