2

When editing with vi or vim "insert" or replace popup text does not appear when in insert or replace mode. This problem occurs both with Windows 7 and Putty interface and with Mac and Iterm2 interface. Also, the problem is strange since it does not appear for one Windows 7 PC I use.

  • 2
    What is the output of :set showmode? ? – Sato Katsura Oct 10 '15 at 5:46
  • No response from ':set showmode' while in vi or vim. Also, I failed to mention the problem is strange since the problem does not arise on one Windows 7 PC I use. – Jess Oct 10 '15 at 12:29
  • The question mark is part of the command, :set showmode?, not just :set showmode. – Sato Katsura Oct 10 '15 at 15:58
  • Do you use a .vimrc on your machines? Perhaps you are one nocompatible option away ... – VanLaser Oct 10 '15 at 17:19
1

The showmode option is automatically enabled when you run Vim in "nocompatible mode" and automatically disabled if you run Vim in "compatible mode".

"compatible mode" is the default, it means Vim tries its best to behave like the original Vi, which is extremely annoying and impractical, therefore it is recommended to run Vim in "nocompatible mode". This can be achieved…

  • by using the -N flag:

    $ vim -N foo.txt
    
  • or by executing that command in Vim:

    :set nocompatible
    
  • or by having a custom vimrc (empty or not) at any one of these default locations:

    on unix-like systems

    $HOME/.vimrc
    $HOME/.vim/vimrc
    

    on windows

    %userprofile%\_vimrc
    %userprofile%\vimfiles\vimrc
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.