4

When I use <c-p> to autocomplete, a list of possible completions appears, which can be annoying. Can this be disabled?

4

You can use set completeopt=longest which will insert the longest common text of the matches. (:h 'completeopt')

Be sure not to have menu nor menuone in 'completeopt' to disable the autocompletion menu.

This way when you'll trigger autocomplete with <C-n> or <C-p> you will not have the menu open but the word will be complete with as many letters as possible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.