2

Not sure how to explain this but basically I'm using an external plugin/dll to enable fullscreen in gvim (which is very lame since this should be a built-in feature...).

The problem in when I open a window in a horizontal split, vim's cmd line gets offset up a little bit, I'd have to exit/enter fullscreen mode again to get it back to the bottom of the screen.

Here's a video demonstrating the problem: https://youtu.be/Ad__lRMoCc8

Here's my entire setup: https://github.com/vexe/vim

I truly appreciate any help as this has been frustrating me a lot...

[Edit] Just tested it without fullscreen, it's still the same issue. i.e. open a normal gvim window (not in fullscreen) and then open something in a horizontal split, the cmd line will get offseted as well... I would have to move the window around, maximize/unmaximize it etc to get the line back to the bottom of the window.

[Edit] Running gvim.exe without my _vimrc/_gvimrc, the issue is not there...

1

I have found the culprit!

set laststatus=0

For some reason hiding that statusline and doing a horizontal split will cause the issue. Setting it to 1 (default value: show status line when there's more than one window) will not cause any offsetting of the cmd line!

BUT I do NOT want a status line at all! Does anybody know a way around this? This sounds ridiculous but is there anyway to not have the statusline and not suffer from this issue? how about an empty statusline? I tried set statuesline= but it didn't do anything, I still see "filename-------" in the statusline (noruler is also set)

Edit: I set the horizontal split chars to whitespace (after walking into this caveat) via set fillchars=stl:\ notice the escaped space via \

But now I'm still stuck with the filename at the beginning of the status line.

Edit: Used space for statusline set statusline=\

But there's still an annoying empty line above the cmd line, not as annoying as the initial situation but still... if anyone has a better solution please let me know.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.