5

It seems like any time I edit a file with gvim it creates a litany of files I don't want or seem to need. I understand the <filename>.~ files are backups of the file before I started editing and .<filename>.swp are swap files holding bits of data only while vim is open, but what is the purpose of <filename>.project.vim? Can I safely delete them? Can I make gvim stop creating them in the first place?

  • I don't believe that is a standard file for vim to create. Can you please try running vim with -u NONE (i.e. no ~/.vimrc to see if it still does it? – Andrew Ferrier Feb 5 '15 at 21:36
  • @AndrewFerrier That's a negative. Also it only does it for files in some directories. I tested in a scratch area and it doesn't do it, but for example a git repo with a bunch of LaTeX stuff in it leaves them behind on every edit. – Caleb Feb 5 '15 at 21:42
  • So it sounds to me, therefore, like you are loading a plugin which does that instead. Suggest you do a binary search (aka comment half of them) for the plugins you have installed to narrow down the culprit. – Andrew Ferrier Feb 5 '15 at 21:43
  • 1
    @AndrewFerrier How about grep -R project.vim ~/.vim? It looks like Automatic LaTeX Plugin is to blame. I edit so many LaTeX files these days I didn't notice it wasn't happening except on these. That gives me a place to look for how to shut it off. Either I'll answer someday or anybody that looks up how ATP works can answer... – Caleb Feb 5 '15 at 21:57
6

From doc/automatic-tex-plugin.txt in the Automatic LaTeX Plugin source:

                                                *b:atp_ProjectScript*
                                                *g:atp_ProjectScript*
Setting one of the variables |b:atp_ProjectScript| or
|g:atp_ProjectScript| to 0 the feature will be turned off.  Local
variable, i.e. b: has precedence over the global one g:.  So you can
turned off the feature for only specific files. The global variable
will turn it off for all files.

So simply adding:

let g:atp_ProjectScript = 0

to your .vimrc should solve the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.