0

After a lot of years using Vim, I recently moved to NeoVim, especially motivated by this project that helps to setup your configuration via Nix. Using that project as starting point, I started to add bits and bytes from other people's configuration.

At this point, I'm more or less happy with my setup, except for some rough edges.

One of this rough edges, is that different characters of the highlighted line are also highlighted. A couple of examples:

enter image description here

enter image description here

Honestly, I'm not sure where to start looking for a solution. I checked the Catppuccin theme configuration, but I did not find anything related to "arbitrary highlighted characters".

My question is, what plugin or part of the configuration is highlighting the characters? Then, I'll see how to change that behaviour.

In case anyone is interested in my full NeoVim configuration, it is in this repository

4
  • 1
    You need to debug your vimrc. I'm voting to close as "needs details or clarity".
    – Friedrich
    Commented Jun 5 at 16:00
  • Enabling plugins one by one until I find the "one to blame" is of course an option. However, I do not agree with closing the question because "needs details or clarity", at the moment, I'm looking for ways to provide more clarity or details. I would had enough information to understand the issue by myself, I'd have never asked.
    – Manuel
    Commented Jun 5 at 20:15
  • First, my close vote is not an act of unkindness. It's not "against you". Nobody is blaming you for having a question or for having asked. The best anybody could do right now is to debug your plugins and that person should be you. Second, don't enable your plugins one by one but perform a bisection. You'll have your answer in half an hour.
    – Friedrich
    Commented Jun 5 at 20:39
  • 1
    See What is a "closed" or "duplicate" question, and how does question closing work?, What does it mean if a question is "closed"?, etc. As it stands, this question requires answerers to make guesses at solutions, which is not a good fit for this site's Q&A model. The tips in How do I debug my vimrc? are certainly the fastest path to understanding and solving the problem.
    – D. Ben Knoble
    Commented Jun 6 at 0:38

1 Answer 1

1

It looks to me like the quick-scope plugin.

It highlight a unique letter in each word to let you jump directly to it using the f & t motion.

Remark: It was actually a Neovim clone of quick-scope: eyeliner.nvim

4
  • 1
    I do not have that plugins installed. I checked for similar plugins and I saw that "hop" and "lightspeed" have similar functionalities. However, none of them are installed. I also tried using the commands that disable them, just in case they are active. No luck. So it must be one of the plugins I have installed, that simulates the same behaviour.
    – Manuel
    Commented Jun 5 at 20:05
  • Your nvim folder seems rather clean. I would try to delete the nvim-data (take a backup :-)) folder to see if the problem persist. Commented Jun 6 at 0:16
  • 1
    You pointed me in the right direction :-). It was a motion plugin, in this case eyeliner. Your answer gave the key words, "motion" "f" and "t". A grep on my config show me a comment attached to this plugin saying "Highlights unique characters for f/F and t/T motions". Thanks a lot.
    – Manuel
    Commented Jun 6 at 8:04
  • Thanks for the feedback :-) I didn't knew the eyeliner plugin, thanks for that. I'll adapt the answer. Commented Jun 6 at 8:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.