I run Vim in WSL and I build my C++ project in a docker container.

I managed to setup everything, but after the build process I get weird characters in the quickfix list, like the following:

[01m[/home/myname/unit_testing/app/src/utility/main.cpp|3 col 14| [m[K [01;35m[

Any idea on how to fix it?

  • 1
    They are escape sequences produced by whatever is outputting/filtering the errors, for formatting, styling, etc. Well written command-line tools shouldn't use any of those by default when used in a non-interactive context (see --color=yes|no|auto in ls). You should be able to find how to get rid of those in the doc of whatever tools you are using.
    – romainl
    Commented Apr 16 at 18:09

1 Answer 1


The problem relied in that docker was run with the -it flag which means to run the container in interactive mode. By removing such a flag the problem has been solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.