1

When I type something on insert mode and press escape to get normal mode, the cursor goes away and the Neovim does something behind the scenes for a couple of seconds. I can stop this behaviour with ctrl + c and continue on normal mode.

Is there a way to find out what happens behind the scenes to figure out which process takes this long? I suspect it's related to LSP or formatters but rather than doing a binary search on my plugins, I would like to know my other options.

5
  • Could you tell us what is the filetype of the buffer that you are editing (using the :set filetype? Neovim command)? Coud you tell us what dedicated plugin you have for that filetype? Mar 20 at 11:49
  • Do you have still something open in your question? How can we help you further? Otherwise maybe could you accept the answer using the v button next to the arrow voting buttons. It allow the question to rest :-) Mar 21 at 13:32
  • Unfortunately, the problem was resolved before I could try your suggestion. 🤷‍♂️
    – ogirginc
    Mar 25 at 7:59
  • Good to know that the problem is solved :-) How did you solved the problem? Maybe could you publish your own solution and accept it (you'll have to wait two days after publication for that). It allow the question to rest :-) Mar 25 at 9:05
  • 1
    Probably a lazyvim package was the problem and it was solved after a couple of hours. Not sure though. Just a hunch.
    – ogirginc
    Mar 25 at 18:27

1 Answer 1

1

I would investigate a number of triggers using the following commands:

:autocmd InsertLeavePre
:autocmd InsertLeave
:autocmd ModeChanged

This could give you an idea of what is executed when you leave the Insert mode.

In LazyVim the Linter, via the nvim-lint plugin, is associated to the InsertLeave event. I suspect that your Linter is triggered at that moment and is not responsive enough.

Not the answer you're looking for? Browse other questions tagged or ask your own question.