0

I’m using nvim within a PuTTY terminal and I’m having trouble with the Arrow Keys and the Ctrl + Arrow keys. Both keys generate identical character sequences, leading to some complications.

While I was able to address this in vim by setting t_ks and t_ke to empty, it appears that these options aren't available in nvim according to link.

The application cursor keys mode in PuTTY's settings cannot be disabled due to its interference with navigation in other tools like man, ranger, mc, htop, etc.

Interestingly enough, the Ctrl + Arrow keys work perfectly when I use nvim inside tmux.

I'm under the impression that a change in the terminal settings could be necessary.

So, I would like to know how I can prevent Neovim from starting in application cursor key mode when operating inside PuTTY.

Configs:

  • Terminal > Features > Disable application cursor keys mode is unchecked.

  • Terminal > Keyboard > Shift/Ctrl/Alt with the arrow keys set to xterm-style-bitmap

$ cat /usr/share/doc/tmux/example_tmux.conf:

# Change the default $TERM to tmux-256color
set -g default-terminal "screen-256color"

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.