0

Some parts of my code, apparently at random, are rendered in italics, and when I type it goes back and forth from italics to normal.

Why is that and how I can avoid that?

enter image description here

EDIT: Contrary to what I stated previously, changing colorscheme does indeed seem to fix the problem.

Then how can I use my colorscheme without the italics? Is there a way to overwrite that after the colorscheme has loaded?

3
  • What colorscheme is that? Did you try its documentation? Its issue tracker?
    – romainl
    Feb 14 at 17:44
  • 1
    Contrary to what I contrary said in my previous comment, changing the colorscheme does not fix it. It seems to be spurred by calling iron.nvim's functions, and it only happens in WezTerm. It doesn't happen on kitty. Feb 14 at 17:46
  • Yeah kitty has the same problem if using a font that provides italics. Previously I was using "Fira Code Nerd Font" which doesn't have italics. Kitty just ignores the request and render everything in regular. While WezTerm seems to build an italics version of the font. But if I use a font with italics in kitty the problem popups up. Looks like vim randomly requests italic font. Feb 14 at 17:58

1 Answer 1

1

It was iron.nvim's highlights, which are italics by default.

To work around the bug and disable highlights, use:

highlight=false

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.