0

I am using Alacritty terminal on MacOS and when I am type commands in Normal mode sometimes it writes them over the text. For example, when moving with l, it prints the l in an empty space it finds in the text. Or sometimes it prints long sequences of Control commands over the text in the buffer.

This is garbled output, because the text on the buffer is not really modified, it only looks that way. However, the written commands are persistent somehow.

Steps to reproduce the problem:

  1. Create a new file in Vim or open an old one.
  2. While in Normal mode press k and keep it pressed until it starts writing the k command in the terminal.

Result: Three consecutive ks are written on the terminal.

What could be the problem? I was researching on Google and it could be the terminal. Some users have experienced something similar on Ubuntu on different terminals.

Troubleshooting:

Trying with vim -u NONE shows the same behavior. By changing set visual bell to set belloff=all, it improved somewhat. When moving the cursor all the way up with k, it sometimes prints the command under the cursor, but clears it when moved. Nevertheless, when I scroll the mouse all the way up, it starts inserting random characters with Control.

When commenting this setting: "set showcmd", the cursor stops blinking randomly. However, it keeps recording the commands and when scrolling up with the mouse the screen keeps getting filled with random characters.

7
  • 2
    If you have the same problem in other terminal emulators with $ vim -Nu NONE, use Vim's issue tracker. If the problem is restricted to that terminal emulator, use its support channels.
    – romainl
    Commented Feb 9 at 16:43
  • 1
    Need more information. What is your $TERM setting? have you tried other terminals? Commented Feb 9 at 19:59
  • 1
    Do you have the alacritty terminfo file installed? It should come with a homebrew install. What versions of all involved programs?
    – D. Ben Knoble
    Commented Feb 9 at 22:35
  • 1
    And do check the other terminals with a proper TERM
    – D. Ben Knoble
    Commented Feb 9 at 22:36
  • 2
    Issue is fixed: github.com/vim/vim/issues/14001 Commented Feb 9 at 23:12

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.