0

I'm using this minimal setup (note that I'm on Windows and that I couldn't recreate this problem on Linux):

filetype plugin indent on
filetype plugin on

call plug#begin()
Plug 'Robitx/gp.nvim'
Plug 'vim-syntastic/syntastic'
call plug#end()

lua require('gp').setup()

For some reason after using :GpChatNew, writing something in the buffer and then :GpChatRespond, I get following error:

Gp: File "C:\\Users\\User\\AppData\\Local\\nvim-data\\gp\\chats\\timestamp.md" does not look like a chat file.

In addition to that, gp.nvim hotkeys (such as <C-g><C-g>) do not work at all in gp buffer when syntastic is enabled. Removing syntastic makes gp.nvim work completely as intended.

I tried disabling syntastic in gp buffers like following:

let g:syntastic_disabled_filetypes = ['markdown']
let g:syntastic_ignore_files = ['\Vgp\\\\chats\\\\', '\Vgp\/chats\/']

But neither of these change anything (I've also tried multiple different regex-es such as trivial "chats" etc.).

I have no idea how I can debug this, thanks in advance.

1
  • 1
    FYI: Syntastic was deprecated two years ago. Consider switching to a maintained plugin.
    – Friedrich
    Jan 31 at 15:25

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.