1

My vim-airline has an unexpected ? symbol next to the program being run: enter image description here

I have tried manually setting the airline_symbols from here, for ex: let g:airline_left_sep = '>' and so on but this does not seem to do anything about the ? symbols next to vim and utf-8 on the right hand side.

As you can see from the rc file (below), I have also done let g:airline_section_y = '' but this does not seem to be removing the utf-8 tag from the airline bar.

How can I fix this?

This is my rc file (excluding plugins because it is too long):

" Color Schemes and Themes
set t_Co=256
set background=dark
colorscheme toast
highlight Normal ctermbg=NONE
highlight nonText ctermbg=NONE
let g:airline_theme='deus'
let g:airline_section_y = ''
let g:airline_section_z = '(%l,%c)'

" Basic Vim Settings
set number
set relativenumber
set autoindent
set tabstop=4
set shiftwidth=4
set smarttab
set softtabstop=4
set mouse=a

" NERDTree Keybindings
" <C-t> refers to <control+t>
nnoremap <C-t> :NERDTreeToggle<CR>
set encoding=UTF-8
2
  • I believe this symbol is g:airline_right_sep. What is the result of :echo g:airline_right_sep? Jan 17 at 23:57
  • 1
    Setting g:airline_right_sep to my .vimrc does not fix this. It adds the '<' as a separator between the different sections and you can see it but the ? symbol still remains exactly where it was. Jan 18 at 15:44

1 Answer 1

0

I would try:

let g:airline_symbols_ascii = 1
let g:airline_right_alt_sep = '>'
let g:airline_right_sep = '<'
3
  • 1
    Perhaps an explanation of why you would do this? (Like me, you probably suspect a font issue?)
    – D. Ben Knoble
    Jan 18 at 15:56
  • 1
    Your "I would try <vimsrcipt>" answers keep piling up in the low quality posts queue. Maybe add some explanation to satisfy SE's algorithm?
    – Friedrich
    Jan 20 at 20:17
  • @Friedrich Thanks for telling me :-) I try first to find what is the problem. Without being able to reproduce it :-/ Jan 20 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.