I'm trying to configure tsserver via neovim lspconfig. Currently I am trying to enable logging to verbose mode:

lspconfig.tsserver.setup {
  on_attach = on_attach,
  capabilities = capabilities,
  root_dir = lspconfig.util.root_pattern ".git",
  settings = {
    typescript = {
      tsserver = {
        enableTracing = true,
        log = "verbose",

When I run :LspLog I do not see any logs from tsserver. Is my configuration correct? I have tried multiple variants passing the settings, but nothing worked so far. Thanks

1 Answer 1


In the configuration docs under tsserver options:

  • log is named logVerbosity.
  • enableTracing is named trace.

Both of those names could have been changed since the question was asked. It seems likely the original problem was a result of using the old configuration keys.

  • Welcome to Vi & Vim SE and thank you for posting an answer. If this actually solves OP's problem, you should edit and explain how exactly. If it's just a hint, it should probably be a comment, not an answer (you would need to have 50 reputation before you'll be allowed to comment).
    – Friedrich
    Commented Apr 20 at 15:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.