1

I used to have the following key mappings within _vimrc:

nmap è "_ddP
nmap ò yaw
nmap à "_dwP
nmap § .n

working in Vim 7.4 on Windows and an Italian keyboard. Now, after upgrading to Vim 9.0, they don't work anymore.

They are logged in the output of verbose map as:

n  <a7>          .n
n  <e0>          "_dwP
n  <e8>          "_ddP
n  <f2>          yaw

How can I fix the problem?

2
  • Could you tell us what is the fileencoding of your .vimrc file? When your .vimrc file is open what is the result of the following two commands :set fileencoding?, :set encoding?? Jan 11 at 10:46
  • 1
    @VivianDeSmedt fileencoding=latin1, encoding=utf-8. Jan 11 at 10:51

1 Answer 1

1

I suspect the encoding your .vimrc to be latin1 where Vim 9.0 is detecting it as utf-8.

One solution is to convert your .vimrc to utf-8.

You could do that by running the following command on your .vimrc.

:set fileencoding=utf8
:w

After restarting Vim it should run correctly.

Another option is to explicitly tell Vim that your .vimrc file is encoded in latin1 by adding the following line as the first line of your .vimrc file:

" vim: set fileencoding=latin1 :

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.