1

I installed Kanagawa plugin using vim-plug.

When I tried to change the colorscheme with:

:colorscheme kanagawa

I got the following error :

>- Error detected while processing /home/mmip/.local/share/nvim/site/plugged/kanagawa.nvim/colors/kanagawa.vim:                                          
>- line    1:                                                                                                                                            
>E5108: Error executing lua [string ":lua"]:1: loop or previous error loading module 'kanagawa'                                                        
>- stack traceback:                                                                                                                                      
>           [C]: in function 'require'                                                                                                                    
>           [string ":lua"]:1: in main chunk

I have been trying to figure it out looking to this post (very similar question), but eventually I didn't manage to solve the problem.

Here is how I installed the plugin using vim-plug : in my init.vim file I added:

Plug 'rebelot/kanagawa.nvim'

Inside the

call plug#begin('~/.local/share/nvim/site/plugged
" ...
call plug#end()

Then I called:

:PlugInstall.

My version of nvim is v0.6.1.

7
  • Welcome to Vim. It seems that the plugin is installed in nvim/site where I would expect it in nvim-data/plugged. Could you share with use how did you install the plugin using Vim-Plug? Could you share your version of Neovim? Nov 25, 2023 at 0:51
  • Please don’t post images of text. You can edit to add the error message.
    – D. Ben Knoble
    Nov 25, 2023 at 12:07
  • 1
    @VivianDeSmedt, I installed the plugin by calling PlugInstall after adding Plug 'rebelot/kanagawa.nvim inside the "call plug" part at the top of my init.vim file (I edited my question with more details). I use nvim v0.6.1. Nov 25, 2023 at 13:12
  • Thanks. I'll try to reproduce the problem. How did you activate the colorscheme? Nov 25, 2023 at 14:36
  • @VivianDeSmedt, I activated the colorscheme with :colorscheme kanagawa. Nov 26, 2023 at 19:03

1 Answer 1

0

In my test the kanagawa colorscheme requiers Neovim 8.0.

It seems to me that Neovim 6.1 doesn't yet support colorscheme developed in Lua.

Apparently kanagawa colorscheme requiers some standard highlighting groups that are not yet standard in Neovim 7.0.

I suggest to migrate to Neovim 8.0 or above.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.