0

I am trying to use these configurations for neovim, but every time I start the editor I get:

Error detected while processing /home/user/.config/nvim/init.lua:
E5113: Error while calling lua chunk: ...ason-null-ls.nvim/lua/mason-null-ls/ensure_installed.lua:11: attempt to call field 'has_package' (a nil value)
stack traceback:
        ...ason-null-ls.nvim/lua/mason-null-ls/ensure_installed.lua:11: in function 'mapper_fn'
        ...pack/packer/start/mason.nvim/lua/mason-core/optional.lua:34: in function 'resolve_package'
        ...ason-null-ls.nvim/lua/mason-null-ls/ensure_installed.lua:26: in function <...ason-null-ls.nvim/lua/mason-null-ls/ensure_installed.lua:21>
        ...cker/start/mason-null-ls.nvim/lua/mason-null-ls/init.lua:88: in function 'setup'
        /home/user/.config/nvim/lua/jesme/plugins/lsp/mason.lua:42: in main chunk
        [C]: in function 'require'
        /home/user/.config/nvim/init.lua:10: in main chunk
Error in packer_compiled: vim/_editor.lua:0: /home/user/.config/nvim/plugin/packer_compiled.lua..nvim_exec2() called at /home/user/.config/nvim/plugin/packer_compiled.lua:0../home/user/.local/share/nvim/site/pack/packer
/start/nvim-treesitter/plugin/nvim-treesitter.lua: Vim(packadd):E5113: Error while calling lua chunk: /usr/share/nvim/runtime/lua/vim/treesitter/query.lua:533: Overriding has-ancestor?^@stack traceback:^@^I[C]: in function 'erro
r'^@^I/usr/share/nvim/runtime/lua/vim/treesitter/query.lua:533: in function 'add_predicate'^@^I...nvim-treesitter/lua/nvim-treesitter/query_predicates.lua:64: in main chunk^@^I[C]: in function 'require'^@^I...ack/packer/start/nv
im-treesitter/lua/nvim-treesitter.lua:8: in main chunk^@^I[C]: in function 'require'^@^I.../packer/start/nvim-treesitter/plugin/nvim-treesitter.lua:9: in main chunk^@^I[C]: in function 'nvim_exec2'^@^Ivim/_editor.lua: in functio
n 'cmd'^@^I/home/user/.config/nvim/plugin/packer_compiled.lua:244: in function </home/user/.config/nvim/plugin/packer_compiled.lua:10>^@^I[C]: in function 'pcall'^@^I/home/user/.config/nvim/plugin/packer_compiled.lua:10
: in main chunk
Please check your config for correctness

What is the cause of these errors and how can I fix them?

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.