1

When I move the cursor upwards, the whole line (including the number) shifts one character to the left. The GIF explains it the best.

I'm using Neovim installed in Windows but opened through WSL running on Windows Terminal. This doesn't happen if I open Neovim directly from Windows, only when I open it through the terminal. I've tried some simple fixes - turning off themes and disabling numbers, but I can't think of how to troubleshoot this.

  enter image description here

3
  • 1
    Do you have it with a bare configuration? nvim -i NONE -u NONE? Oct 24, 2023 at 4:59
  • 1
    just a guess: :set conceallevel=0 concealcursor= Oct 24, 2023 at 5:39
  • Both of these solutions didn't work, sadly, but I disabled the cursorline and that fixed it.
    – vvenk
    Oct 29, 2023 at 17:02

1 Answer 1

0

Figured it out - apparently the cursorline was causing this bug. Not sure what the root cause is, but disabling that fixed this issue.

1
  • 2
    Glad you solved your problem and posted an answer. Would be great if somebody could explain the root cause.
    – Friedrich
    Oct 29, 2023 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.