0

Run make CMAKE_BUILD_TYPE=RelWithDebInfo got following errors:

With little knowledge of lua, I have no idea how to solve this...

touch build/.ran-cmake
ninja  -C build
ninja: Entering directory `build'
[0/2] Re-checking globbed directories...
[1/398] cd /home/name/neovim-git/neovim/build/src/nvim && /usr/bin/cmake -D NVIM_VERSION_MAJOR=0 -D NVIM_VERSION_MINOR...ndef_git.h -D NVIM_SOURCE_DIR=/home/name/neovim-git/neovim -P /home/name/neovim-git/neovim/cmake/GenerateVersion.cmake
-- Using NVIM_VERSION: v0.9.2
[2/398] Generating auto/api/autocmd.c.generated.h, ../../include/api/autocmd.h.generated.h
FAILED: src/nvim/auto/api/autocmd.c.generated.h include/api/autocmd.h.generated.h /home/name/neovim-git/neovim/build/src/nvim/auto/api/autocmd.c.generated.h /home/name/neovim-git/neovim/build/include/api/autocmd.h.generated.h 
cd /home/name/neovim-git/neovim/build/src/nvim && /usr/bin/cc /home/name/neovim-git/neovim/src/nvim/api/autocmd.c -E -o /home/name/neovim-git/neovim/build/src/nvim/auto/api/autocmd.i -DDO_NOT_DEFINE_EMPTY_ATTRIBUTES -D_GNU_SOURCE -I/home/name/neovim-git/neovim/.deps/usr/include/luajit-2.1 -I/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/build/src/nvim/auto -I/home/name/neovim-git/neovim/build/include -I/home/name/neovim-git/neovim/build/cmake.config -I/home/name/neovim-git/neovim/src -Iprop-NOTFOUND -Iprop-NOTFOUND -I/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -O2 && /usr/bin/luajit /home/name/neovim-git/neovim/src/nvim/generators/gen_declarations.lua /home/name/neovim-git/neovim/src/nvim/api/autocmd.c /home/name/neovim-git/neovim/build/src/nvim/auto/api/autocmd.c.generated.h /home/name/neovim-git/neovim/build/include/api/autocmd.h.generated.h /home/name/neovim-git/neovim/build/src/nvim/auto/api/autocmd.i
PANIC: unprotected error in call to Lua API (26)
[3/398] Generating auto/api/extmark.c.generated.h, ../../include/api/extmark.h.generated.h
FAILED: src/nvim/auto/api/extmark.c.generated.h include/api/extmark.h.generated.h /home/name/neovim-git/neovim/build/src/nvim/auto/api/extmark.c.generated.h /home/name/neovim-git/neovim/build/include/api/extmark.h.generated.h 
cd /home/name/neovim-git/neovim/build/src/nvim && /usr/bin/cc /home/name/neovim-git/neovim/src/nvim/api/extmark.c -E -o /home/name/neovim-git/neovim/build/src/nvim/auto/api/extmark.i -DDO_NOT_DEFINE_EMPTY_ATTRIBUTES -D_GNU_SOURCE -I/home/name/neovim-git/neovim/.deps/usr/include/luajit-2.1 -I/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/build/src/nvim/auto -I/home/name/neovim-git/neovim/build/include -I/home/name/neovim-git/neovim/build/cmake.config -I/home/name/neovim-git/neovim/src -Iprop-NOTFOUND -Iprop-NOTFOUND -I/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -O2 && /usr/bin/luajit /home/name/neovim-git/neovim/src/nvim/generators/gen_declarations.lua /home/name/neovim-git/neovim/src/nvim/api/extmark.c /home/name/neovim-git/neovim/build/src/nvim/auto/api/extmark.c.generated.h /home/name/neovim-git/neovim/build/include/api/extmark.h.generated.h /home/name/neovim-git/neovim/build/src/nvim/auto/api/extmark.i
PANIC: unprotected error in call to Lua API (26)
[4/398] Generating auto/api/deprecated.c.generated.h, ../../include/api/deprecated.h.generated.h
FAILED: src/nvim/auto/api/deprecated.c.generated.h include/api/deprecated.h.generated.h /home/name/neovim-git/neovim/build/src/nvim/auto/api/deprecated.c.generated.h /home/name/neovim-git/neovim/build/include/api/deprecated.h.generated.h 
cd /home/name/neovim-git/neovim/build/src/nvim && /usr/bin/cc /home/name/neovim-git/neovim/src/nvim/api/deprecated.c -E -o /home/name/neovim-git/neovim/build/src/nvim/auto/api/deprecated.i -DDO_NOT_DEFINE_EMPTY_ATTRIBUTES -D_GNU_SOURCE -I/home/name/neovim-git/neovim/.deps/usr/include/luajit-2.1 -I/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/build/src/nvim/auto -I/home/name/neovim-git/neovim/build/include -I/home/name/neovim-git/neovim/build/cmake.config -I/home/name/neovim-git/neovim/src -Iprop-NOTFOUND -Iprop-NOTFOUND -I/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -O2 && /usr/bin/luajit /home/name/neovim-git/neovim/src/nvim/generators/gen_declarations.lua /home/name/neovim-git/neovim/src/nvim/api/deprecated.c /home/name/neovim-git/neovim/build/src/nvim/auto/api/deprecated.c.generated.h /home/name/neovim-git/neovim/build/include/api/deprecated.h.generated.h /home/name/neovim-git/neovim/build/src/nvim/auto/api/deprecated.i
PANIC: unprotected error in call to Lua API (26)
[5/398] Generating auto/api/buffer.c.generated.h, ../../include/api/buffer.h.generated.h
FAILED: src/nvim/auto/api/buffer.c.generated.h include/api/buffer.h.generated.h /home/name/neovim-git/neovim/build/src/nvim/auto/api/buffer.c.generated.h /home/name/neovim-git/neovim/build/include/api/buffer.h.generated.h 
cd /home/name/neovim-git/neovim/build/src/nvim && /usr/bin/cc /home/name/neovim-git/neovim/src/nvim/api/buffer.c -E -o /home/name/neovim-git/neovim/build/src/nvim/auto/api/buffer.i -DDO_NOT_DEFINE_EMPTY_ATTRIBUTES -D_GNU_SOURCE -I/home/name/neovim-git/neovim/.deps/usr/include/luajit-2.1 -I/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/build/src/nvim/auto -I/home/name/neovim-git/neovim/build/include -I/home/name/neovim-git/neovim/build/cmake.config -I/home/name/neovim-git/neovim/src -Iprop-NOTFOUND -Iprop-NOTFOUND -I/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -O2 && /usr/bin/luajit /home/name/neovim-git/neovim/src/nvim/generators/gen_declarations.lua /home/name/neovim-git/neovim/src/nvim/api/buffer.c /home/name/neovim-git/neovim/build/src/nvim/auto/api/buffer.c.generated.h /home/name/neovim-git/neovim/build/include/api/buffer.h.generated.h /home/name/neovim-git/neovim/build/src/nvim/auto/api/buffer.i
PANIC: unprotected error in call to Lua API (26)
[6/398] Generating auto/api/command.c.generated.h, ../../include/api/command.h.generated.h
FAILED: src/nvim/auto/api/command.c.generated.h include/api/command.h.generated.h /home/name/neovim-git/neovim/build/src/nvim/auto/api/command.c.generated.h /home/name/neovim-git/neovim/build/include/api/command.h.generated.h 
cd /home/name/neovim-git/neovim/build/src/nvim && /usr/bin/cc /home/name/neovim-git/neovim/src/nvim/api/command.c -E -o /home/name/neovim-git/neovim/build/src/nvim/auto/api/command.i -DDO_NOT_DEFINE_EMPTY_ATTRIBUTES -D_GNU_SOURCE -I/home/name/neovim-git/neovim/.deps/usr/include/luajit-2.1 -I/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/build/src/nvim/auto -I/home/name/neovim-git/neovim/build/include -I/home/name/neovim-git/neovim/build/cmake.config -I/home/name/neovim-git/neovim/src -Iprop-NOTFOUND -Iprop-NOTFOUND -I/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -O2 && /usr/bin/luajit /home/name/neovim-git/neovim/src/nvim/generators/gen_declarations.lua /home/name/neovim-git/neovim/src/nvim/api/command.c /home/name/neovim-git/neovim/build/src/nvim/auto/api/command.c.generated.h /home/name/neovim-git/neovim/build/include/api/command.h.generated.h /home/name/neovim-git/neovim/build/src/nvim/auto/api/command.i
PANIC: unprotected error in call to Lua API (26)
[7/398] Generating auto/api/options.c.generated.h, ../../include/api/options.h.generated.h
FAILED: src/nvim/auto/api/options.c.generated.h include/api/options.h.generated.h /home/name/neovim-git/neovim/build/src/nvim/auto/api/options.c.generated.h /home/name/neovim-git/neovim/build/include/api/options.h.generated.h 
cd /home/name/neovim-git/neovim/build/src/nvim && /usr/bin/cc /home/name/neovim-git/neovim/src/nvim/api/options.c -E -o /home/name/neovim-git/neovim/build/src/nvim/auto/api/options.i -DDO_NOT_DEFINE_EMPTY_ATTRIBUTES -D_GNU_SOURCE -I/home/name/neovim-git/neovim/.deps/usr/include/luajit-2.1 -I/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/build/src/nvim/auto -I/home/name/neovim-git/neovim/build/include -I/home/name/neovim-git/neovim/build/cmake.config -I/home/name/neovim-git/neovim/src -Iprop-NOTFOUND -Iprop-NOTFOUND -I/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -I/home/name/neovim-git/neovim/.deps/usr/include -O2 && /usr/bin/luajit /home/name/neovim-git/neovim/src/nvim/generators/gen_declarations.lua /home/name/neovim-git/neovim/src/nvim/api/options.c /home/name/neovim-git/neovim/build/src/nvim/auto/api/options.c.generated.h /home/name/neovim-git/neovim/build/include/api/options.h.generated.h /home/name/neovim-git/neovim/build/src/nvim/auto/api/options.i
PANIC: unprotected error in call to Lua API (26)
ninja: build stopped: subcommand failed.

2
  • I suspect you’ll get more informative responses on GitHub.
    – D. Ben Knoble
    Oct 12, 2023 at 16:40
  • Did you install the dependencies? Is Lua installed on the machine? Oct 12, 2023 at 18:04

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.