1

I'm using kickstart on my vanilla Neovim config and having some troubles with configuring buildFlags for my gopls. I added uncommented gopls and added following config in my init.lua Spent few hours already and no idea why it's not added.

    local servers = {
      -- clangd = {},
      gopls = {
        buildFlags = { '-tags=integration' }, 
      },
      -- pyright = {},
      -- rust_analyzer = {},
      -- tsserver = {},
      -- html = { filetypes = { 'html', 'twig', 'hbs'} },

      lua_ls = {
        Lua = {
          workspace = { checkThirdParty = false },
          telemetry = { enable = false },
        },
      },
    }

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.