2

Please find the refined version below:

In the attached images, the top one displays the syntax highlighting performed by the rust-analyzer Language Server Protocol (LSP), while the bottom image shows the desired result achieved after disabling the rust-analyzer LSP. I personally do not prefer the automatic syntax highlighting, and I find it strange that the behavior of rust-analyzer does not seem to provide an option to enable syntax highlighting in the LSP configuration schema.

Previously, when using Neovim v0.8.3, I did not encounter this issue. However, this problem appeared in versions v9.0.0 and v9.0.1.

I would greatly appreciate any assistance in turning off the bothersome syntax highlighting. Thank you. I installed Neovim using the command sudo apt-get install nvim.

![enter image description here

2
  • In order to help us in our tests could you provide, in body of the question, the rust code in textual form that correspond to the screenshot such that we can reproduce the problem? Commented Jul 12, 2023 at 15:53
  • Do you have Treesitter installed? Commented Jul 12, 2023 at 15:54

1 Answer 1

-1

Resolved by https://github.com/simrat39/rust-tools.nvim/issues/365#issuecomment-1506286437

The answer the link above have a effect to disable the automatic syntax highlight. Thanks.

4
  • 3
    Rather than put junk in your answer, please edit to include the actual information (quotes are acceptable with attribution, for example). We prefer QA to stand on its own rather than depend entirely on links.
    – D. Ben Knoble
    Commented Jul 12, 2023 at 18:33
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Jul 12, 2023 at 19:01
  • Editted. thanks.
    – Hyunsoo
    Commented Jul 13, 2023 at 13:20
  • 1
    Stating "the link has the answer" is still not enough. You should include any details necessary to solve the problem directly in the Answer text.
    – D. Ben Knoble
    Commented Jul 13, 2023 at 19:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.