0

I cross-compiled Vim 9.0 for ARM / arm-linux-gnueabihf (after also cross-compiling ncurses):

# ac_cv_sizeof_int=4 \
vim_cv_getcwd_broken=no \
vim_cv_memmove_handles_overlap=yes \
vim_cv_stat_ignores_slash=yes \
vim_cv_tgetent=zero \
vim_cv_terminfo=yes \
vim_cv_toupper_broken=no \
./configure --build=i586-linux --host=arm-linux-gnueabihf --target=arm-linux-gnueabihf --disable-gui --without-x --disable-selinux --disable-acl --disable-gpm  --with-tlib=tinfo  CPPFLAGS=-I../../INSTALL/include/ncurses LDFLAGS=-L../../INSTALL/lib --prefix=/home/blah/tmp/VIM/INSTALL/

For testing, I'm ssh'd into an Arm Linux Device - it seems to work as an editor all OK. But despite it running in a gnome-terminal, with a $TERM of xterm-256color, aftersyntax on, I only ever seem to still get the default monochrome terminal colouring, with bold and underline highlighting.

The terminal colouring is working:

  • tput colors gives me "256".
  • If I run echo -e "\e[1;34mThis is a blue text.\e[0m", I get blue text.

I installed Vim to /usr/local/... and it was having problems finding the share/vim, until I set VIMRUNTIME=/usr/local/share/vim/vim90.

Is it the vim_cv_tgetent=zero? (EDIT: No, removed this)

Is there anything else I can try?

1 Answer 1

2

The issue turned out to be a non-existent set of terminal information files.

I did copy these up from the ncurses build, but they were never found in /usr/local/share. Setting the correct TERMINFO fixed it.

export TERMINFO=/usr/local/share/terminfo

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.