0

I downloaded nvim.appimage v0.9.1 to run on KDE neon 22.04 5.27 base: Ubuntu 22.04 LTS Jammy. In the terminal, so far, so good.

However, looking at the nvim.appimage --help and also at :help, I haven't found how to run nvim-qt. How can I run nvim-qt?

Thanks!

EDIT: To answer the questions to comments so far: I figured that since nvim-qt is installed alongside nvim when I install Neovim from the package manager, that it would come along with the appimage, too. I installed the appimage because the Ubuntu repo is still on Neovim 0.6.x.

I had hoped to find an option to pass in the cli invocation in the --help or in the :help, but I did not.

I found the --appimage-mount option, so I was able to inspect the contents of the appimage. I don't see nvim-qt in the bin directory, so it seems that I'm looking for something that isn't there.

4
  • Welcome to vi SE. What have you tried so far? What did you expect? What did actually happen? Please edit and tell us.
    – Friedrich
    Jul 3, 2023 at 19:08
  • What makes you think, nvim-qt is part of the Neovim Appimage? Jul 3, 2023 at 19:55
  • So... is your issue solved? Frankly, I don't get what the question is about and the edit didn't help much. It might be just me being stupid. I still don't get the aim behind your actions. I presume you want to run a GUI version of Neovim. Is that what you're trying to do? Is it working? See How to ask?
    – Friedrich
    Jul 4, 2023 at 9:30
  • Ok, let me rephrase my question. I want to run the GUI version of Neovim. Is that possible from nvim.appimage?
    – Eric
    Jul 4, 2023 at 13:32

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.