0

In gvim (started from WSL2), when I am executing a command, for example :! ls -lha the colors are not supported. Also when the :!man is executed, the following is reported:

WARNING: terminal is not fully functional

Is there a way to fix that, i.e. to set a terminal that supports colors ?

1

1 Answer 1

0

as Christian Brabandt suggested, :set guioptions+=! solves the problem.

  '!'   External commands are executed in a terminal window.  Without
    this flag the MS-Windows GUI will open a console window to
    execute the command.  The Unix GUI will simulate a dumb
    terminal to list the command output.
    The terminal window will be positioned at the bottom, and grow
    upwards as needed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.