0

I'm trying to port my nvim configuration to another desktop, but I can't seem to figure out how to make packer work. I enter nvim and I don't see any errors regarding packer at startup, just about plugins that I don't have installed precisely because I can't make packer work. Here my config. I followed the guide on github and copy-pasted

git clone --depth 1 https://github.com/wbthomason/packer.nvim\
 ~/.local/share/nvim/site/pack/packer/start/packer.nvim

Sourcing my init.lua throws me the error loop or previous error loading module 'enrico', so I guess it may be a tree problem. Here my configuration tree

.config/nvim/
├── after
│   └── plugin
│       └── color.lua
├── colors
├── init.lua
├── lua
│   └── enrico
│       ├── init.lua
│       ├── keymap.lua
│       ├── packer.lua
│       └── set.lua
├── plugin
│   └── packer_compiled.lua
├── spell
└── UltiSnips

Any hint is much appreciated

2
  • Do you have the file: ~/.local/share/nvim/site/pack/packer/start/packer.nvim? Jun 4 at 5:20
  • Yes, that wasn't the problem. I managed to solve it but Idk how. I'll update the question later because it could still be useful for someone.
    – enrico223
    Jun 4 at 12:29

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.