0

I am trying to install hop.nvim using packer. I have about 35 other plugins installed without any issues. For some reason, I can't install hop.nvim.

The other plugins install fine if I use :PackerSync.

For some reason, it passes hop.nvim and I don't get any error messages.

This is what I got in my init.lua.

return require('packer').startup(function(use)
-- Packer can manage itself
use 'wbthomason/packer.nvim'
-- If you are using Packer
use 'shaunsingh/nord.nvim'
-- ... other plugins
use {'phaazon/hop.nvim'} 
end)

1 Answer 1

0

I would try:

  use 'phaazon/hop.nvim'

Without the braces.

Or as documented in hop:

use {
  'phaazon/hop.nvim',
  branch = 'v2', -- optional but strongly recommended
  config = function()
    -- you can configure Hop the way you like here; see :h hop-config
    require'hop'.setup { keys = 'etovxqpdygfblzhckisuran' }
  end
}
4
  • I tried both ways. No joy....
    – ThomasDKim
    Apr 24, 2023 at 1:49
  • And if you keep only hop to verify that the problem is not in one of the previous lines (maybe you could give us the full call I stead of the excerpt)? Apr 24, 2023 at 3:41
  • 1
    my mistake. The first line worked. i had to put the setup on a separate lua file. Thank you for your help!
    – ThomasDKim
    Apr 24, 2023 at 4:36
  • Welcome to Vim :-) Thanks for the feedback! Apr 24, 2023 at 5:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.