0

I observed that in the recent update for Vim, specifically vim 9.0.1420, it is now possible to create a text file, open it, and then open the same file through another terminal window without encountering the familiar warning message related to .swp files. This message was previously displayed before the update and helped prevent editing an already opened file. Would anybody help me (scritpnames test, etc) to narrow down the cause of this problem? Thank you.

6
  • I can't repro on 9.0.1450.
    – muru
    Commented Apr 20, 2023 at 3:16
  • "Would anybody help me (scritpnames test, etc) to narrow down the cause of this problem?" Well, why don't you get ahead and do all that right from the bat?
    – romainl
    Commented Apr 20, 2023 at 5:22
  • Welcome to Vim! Can you reproduce the problem when you start Vim with vim -u NONE -i NONE? Can you reproduce the problem with vim --clean? Commented Apr 20, 2023 at 6:26
  • @VivianDeSmedt Thanks. If on one terminal I open vim -u NONE test.txt and through another terminal window vim -u NONE test.txt , I can see the .swp warning. Same with vim --clean test.txt. Could you help me to narrow down where the problem is? Super, many thanks
    – DavidC.
    Commented Apr 20, 2023 at 7:10
  • vim --clean starts Vim without plugins. The "problem" is probably with one of your plugin. My advice would be to do some kind of binary search (disable half of them, disable the other half, ...) to find the culprit. Commented Apr 20, 2023 at 8:52

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.