0

When I open some file I see a list of plugins shown on the whole window (screenshot below). I get tired of wasting my time to press few keys to hide this list: several times Space each time. No error then when the file opened or other bugs follows, only that list of plugins each time. How to hide this list? Is this some bug?.

Sample scenario, steps:

  1. nvim ~/.config/vimrc
  2. Place cursor inside vimrc at "wiki" at line with call minpac#add('lervag/wiki.vim') and press K
  3. Result: list of plugins (see screenshot).

Expected: no list of plugins shown.

The list of plugins

❯ uname -a
Linux ARCHPC 6.2.10-arch1-1 #1 SMP PREEMPT_DYNAMIC Fri, 07 Apr 2023 02:10:43 +0000 x86_64 GNU/Linux
❯ LANG=en nvim --version
NVIM v0.9.0
Build type: Release
LuaJIT 2.1.0-beta3

   system vimrc file: "$VIM/sysinit.vim"
  fall-back for $VIM: "/usr/share/nvim"

:checkhelth:


==============================================================================
coc: health#coc#check

- OK nvim version satisfied
- OK Environment check passed
- OK Javascript bundle build/index.js found
- OK Service started

==============================================================================
nvim: require("nvim.health").check()

Configuration ~
- OK no issues found

Runtime ~
- OK $VIMRUNTIME: /usr/share/nvim/runtime

Performance ~
- OK Build type: Release

Remote Plugins ~
- OK Up to date

terminal ~
- key_backspace (kbs) terminfo entry: `key_backspace=\177`
- key_dc (kdch1) terminfo entry: `key_dc=\E[3~`
- $VTE_VERSION="5602"
- $COLORTERM="truecolor"

==============================================================================
provider: health#provider#check

Clipboard (optional) ~
- OK Clipboard tool found: xclip

Python 3 provider (optional) ~
- `g:python3_host_prog` is not set.  Searching for python3 in the environment.
- Executable: /usr/bin/python3
- Python version: 3.10.10
- pynvim version: 0.4.3
- OK Latest pynvim is installed.

Python virtualenv ~
- OK no $VIRTUAL_ENV

Ruby provider (optional) ~
- WARNING `ruby` and `gem` must be in $PATH.
  - ADVICE:
    - Install Ruby and verify that `ruby` and `gem` commands work.

Node.js provider (optional) ~
- Node.js: v19.8.1
- WARNING Missing "neovim" npm (or yarn, pnpm) package.
  - ADVICE:
    - Run in shell: npm install -g neovim
    - Run in shell (if you use yarn): yarn global add neovim
    - Run in shell (if you use pnpm): pnpm install -g neovim
    - You may disable this provider (and warning) by adding `let g:loaded_node_provider = 0` to your init.vim

Perl provider (optional) ~
- WARNING "Neovim::Ext" cpan module is not installed
  - ADVICE:
    - See :help |provider-perl| for more information.
    - You may disable this provider (and warning) by adding `let g:loaded_perl_provider = 0` to your init.vim

==============================================================================
vim.lsp: require("vim.lsp.health").check()

- LSP log level : WARN
- Log path: /home/art/.local/state/nvim/lsp.log
- Log size: 0 KB

vim.lsp: Active Clients ~
- No active clients

==============================================================================
vim.treesitter: require("vim.treesitter.health").check()

- Nvim runtime ABI version: 14

Update. Comparing this strange list with :scriptnames. The :Files at the top of the left side list (the strange list) is https://github.com/junegunn/fzf. I just reproduced the issue by another way: press Ctrl-P and found and opened a file with '.timeclock' format .

enter image description here

4
  • 1
    What does :verbose map K show? I’m not sure how to connect the keys or the files to the output. Could almost be :scriptnames, but it’s missing the numbers.
    – D. Ben Knoble
    Commented Apr 16, 2023 at 12:35
  • verbose map K : n K * :call ShowDocumentation()<CR>. Actually this list is shown for other files, not only documentation. For examle, a .timeclock file (hledger.org/1.29/hledger.html#timeclock ).
    – Artyom
    Commented Apr 17, 2023 at 11:51
  • No, :scriptnames shows different list. Please see the screenshot in the update. Thank you for your comment
    – Artyom
    Commented Apr 17, 2023 at 11:53
  • I'm away from my computer for a week but I suppose sharing your init.vim and configuration would help to reproduce your problem. Commented May 1, 2023 at 13:48

1 Answer 1

2

And I found the bug. I basically did this: tried without plugins and/or without vimrc (--noplugin, -u NONE, -u NORC). This showed that it is not some plugin (the list appeared with --noplugin). Then I just did the binary search in my vimrc file: comment out half, try reproduce, reproduced?, comment other part, and so on. This way I found that this line of code in my vimrc caused the list to appear. Can only blame myself for putting some configurations without thinking!

Removing this line fixed the bug of the list showing up:

autocmd BufRead * try | execute "compiler ".&filetype | catch /./ | endtry 
2
  • Thank you for sharing your solution. I'm voting to close the question as "unlikely to help future readers".
    – Friedrich
    Commented Aug 24, 2023 at 7:32
  • 1
    My guess is that you saw the list when filetype was empty, as you can see from running :compiler
    – D. Ben Knoble
    Commented Aug 24, 2023 at 13:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.