0

When I use vimwiki and I write past the text width, the bullet point will wrap. This is what I expect. However, the wrap will be a new line:


1. something to say .....
   a second line wrapped after 80 textwidth.        < -- this is a new line

Current settings in my init.lua:

local set = vim.opt

set.wrap = true
set.linebreak = true
set.textwidth = 80

I also have set formatoptions+=r and set formatoptions-=t in my init.vim

I want the second line to wrap but be on the same vim line.

1 Answer 1

0

If you don't want hard wrap (Vim creating new lines to wrap text) you have to set textwidth to 0:

set.textwidth = 0
3
  • I tried that, but then the line goes to the end of the page. Visually I like the wrapping. Is there a way to have it visually but not actually?
    – Vinn
    Apr 13, 2023 at 17:06
  • I don't think so. The approved answer make me think it is not possible. Apr 13, 2023 at 17:26
  • What about tw=0 and wrap? That doesn't hard wrap but does give visual wrapping at the end of the window (and you can control the appearance through other options) @Vinn
    – D. Ben Knoble
    May 14, 2023 at 2:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.