2

I'm using nerd fonts in my terminal.

I setup nvimtree with below config -

  use {
    'kyazdani42/nvim-tree.lua',
    requires = 'kyazdani42/nvim-web-devicons',
    config = function() require'nvim-tree'.setup {} end
  }

Below is my nvim tree config -

require('nvim-tree').setup({
  disable_netrw = true,
  hijack_netrw = true,
  ignore_ft_on_setup = {'dashboard'},
  open_on_tab = false,
    hijack_cursor = true,
    update_cwd = true,
    update_focused_file = {enable = true, update_cwd = true, ignore_list = {}},
    system_open = {
        -- the command to run this, leaving nil should work in most cases
        cmd = nil,
        -- the command arguments as a list
        args = {}
    },
  view = {
    width = 25,
    side = 'left',
    mappings = { custom_only = false, list = {}}
  },
  git = {
    ignore = true
  },
  renderer = {
    indent_markers = {
      enable = true
    }
  }
})

vim.cmd('nnoremap <space>e :NvimTreeToggle<CR>')

local function open_nvim_tree()
  -- open the tree
  require("nvim-tree.api").tree.open()
end
vim.api.nvim_create_autocmd({ "VimEnter" }, { callback = open_nvim_tree })

I've configured nerd font in my terminal application.

Iterm text config

When I open the code in neovim I'm not seeing dev icons

Neovim without icons

My config is here

Any idea what is wrong with my config and how to fix them?

1 Answer 1

2

update your version of nvim, I'm using astro neovim

in the /.config/nvim/lua/plugins directory

go into the ui.lua file and set the 3rd line which is a string to

"nvim-tree/nvim-web-devicons"

It should look like this enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.