2

I do not use syntax highlighting, except for a few elements like errors, matched parentheses, search results, and diffs. Yesterday I updated NeoVim installation to v0.9.0 and now I see colors in for statements, strings, html tags, etc. Based on the release notes I assume this was caused by "treesitter".

Is there a way to revert back to my previous setup?

1 Answer 1

2

Look at vim.treesitter.stop in Neovim docs. It is specific to buffers, but I think you can expand it. The nuclear option I think would be using th module vim.treesitter.highlighter and TSHighlighter:destroy({self}). I suggest you to look at the doc I linked above.

1
  • Thanks for the doc. I read it and seems like tree-sitter highlight groups are linked to Vims highlight groups so this isn't the issue. I tracked the issue down to init.vim not respecting my colorscheme. Colors get back to normal if after starting neovim I manually call :colors again. Apr 9, 2023 at 8:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.